Soucis ubuntu

Modérateurs : Co Admin, Modératrices

Avatar de l’utilisateur
la_tortue
Newser
Newser
Messages : 1152
Enregistré le : 04/12/2006, 00:00
Localisation : fr

Soucis ubuntu

Messagepar la_tortue » 21/03/2007, 10:47

Salut a tous

Je suis actuellement en stage de fin d'étude :cool: mais j'ai un petit probleme avec la distribution linux installée sur mon poste. C'est une Ubuntu 6.10 \"Edgy Eft\".
Quand je suis le net avec firefox et bien le defilement est tres sacadé. Je pense que j'ai un probleme d'installation/configuration des pilotes graphiques.
Le truc c'est comment savoir quelle est la CG du systeme?
Je pense qu'une fois que je sais ça je pourrais me debrouiller.

Maintenant un autre soucis, comment savoir quelles sont les mises à jours installées. On me demande de tenir un fichier de log sur les mises à jours (ce qui permet de savoir quelles sont les versions des logs et autres paquets installés) mais il y avait une option cochée : \"installer les mise à jours de securité sans confirmation\" donc j'ai decoché l'option (comme ça je peux faire un copier coller des infos à l'ecran) mais je pense que certaine mises à jours ont été installé sans que je m'en aperçoive.

Enfin suite à une mise à jour j'ai changé de version de kernel (2.6.17-10 -> 2.6.17-11). Maintenant j'ai 2 nouvelle ligne sur mon multiboot, celles qui correspondent au nouveau kernel. Comment puis-je retirer les ancienne lignes (celles du kernel v 2.6.17-10).

Merci pour vos reponses

A+

Avatar de l’utilisateur
KZ2EDG
Modérateur
Modérateur
Messages : 330
Enregistré le : 21/12/2006, 00:00
Localisation : af

Messagepar KZ2EDG » 21/03/2007, 11:41

Salut la tortue! :wink:

Alors, pour connaitre la carte graphique installée, il faut ouvrir un terminal (Konsole si tu es sous KDE) et taper lspci puis entrée, tu verras la liste du matériel reconnu.

Ensuite pour les mises à jour, toujours dans le terminal, il faut taper ls /var/log/ | grep dpkg , puis cat /var/log/dpkg.log, et là tu auras la liste des mises à jour avec la date.

Et enfin pour l'affichage dans grub au demarrage, il s'agit du choix au niveau du kernel, comme tu as fait une mise à jour il te propose les deux. Personnellement je desinstalle le kernel le plus ancien ce qui fait qu'au prochain démarrage il n'y aura plus que le dernier installé.

Voilà,bonne continuation avec Edgy!

@ciao! :wink:
Ad augusta per angusta
Image

Avatar de l’utilisateur
la_tortue
Newser
Newser
Messages : 1152
Enregistré le : 04/12/2006, 00:00
Localisation : fr

Messagepar la_tortue » 21/03/2007, 11:42

Merci beaucoup mais comment je desinstalle le kernel?

Je suis un peu neuf en tant qu'administrateur sur linux.

A+

Avatar de l’utilisateur
la_tortue
Newser
Newser
Messages : 1152
Enregistré le : 04/12/2006, 00:00
Localisation : fr

Messagepar la_tortue » 21/03/2007, 11:46

Ensuite j'ai bien tapper la commande lspci et voila le resultat pour ma CG :
\"01:00.0 VGA compatible controller: ATI Technologies Inc Unknown device 7187
01:00.1 Display controller: ATI Technologies Inc Unknown device 71a7\"
:x :x :x

Bon deja c'est ATI je vais voir sur le site ubuntu les optimisation possible avec des ATI

A+

P.S.:Il me semblait qu'il existait des problemes avec les pilotes ATI sous ubuntu ça peut venir de la.

Avatar de l’utilisateur
KZ2EDG
Modérateur
Modérateur
Messages : 330
Enregistré le : 21/12/2006, 00:00
Localisation : af

Messagepar KZ2EDG » 21/03/2007, 13:31

Re-hello! :wink:

Pour desinstaller le kernel, c'est simple, je suppose que tu utilises Synaptic pour gérer les paquets, il suffit d'y faire une recherche de linux-image-2.6.17-10, tu devrais donc voir une case verte cochée juste en face du dit kernel et là faire un clic droit de la souris et choisir sélectionner pour suppression complète.

En ce qui concerne la carte ATI, je sais que certains ont des problèmes avec, pour ma part j'ai des cartes Nvidia (no troll inside) qui me donnent entière satisfaction au niveau des pilotes, aussi ne pouvant t'aider sur ce plan, je pense que le forum ubuntu.fr te sera d'un grand secours en cas de pépin.

Voici d'ailleurs le lien pour la documentation relative à la distribution, c'est une bonne mine de renseignements: http://doc.ubuntu-fr.org/

@ciao! :wink:
Ad augusta per angusta
Image

Avatar de l’utilisateur
la_tortue
Newser
Newser
Messages : 1152
Enregistré le : 04/12/2006, 00:00
Localisation : fr

Messagepar la_tortue » 21/03/2007, 13:50

Merci beaucoup

par contre une fois que j'ai selectionné pour suppression complete je fait quoi?
Je pense que si je quitte il ne va rien se passer.

Pour la CG je suis allé faire un tour sur le site de DELL (car ordi DELL a ma disposition) et il semble que ce soit une x1300 pro (ou pas pro?) mais je vais voir sur le site que tu m'a donné maintenant que j'ai une idée de ce que j'ai

A+

Avatar de l’utilisateur
KZ2EDG
Modérateur
Modérateur
Messages : 330
Enregistré le : 21/12/2006, 00:00
Localisation : af

Messagepar KZ2EDG » 21/03/2007, 13:58

Alors, aprés avoir choisi sélectionner pour suppression complète, il suffit de cliquer sur le bouton \"Appliquer\" qui se trouve dans la barre du dessus (à coté de \"Tout mettre à jour\") et la désinstallation se lancera aprés confirmation de ta part.

@ciao! :wink:
Ad augusta per angusta
Image

Avatar de l’utilisateur
la_tortue
Newser
Newser
Messages : 1152
Enregistré le : 04/12/2006, 00:00
Localisation : fr

Messagepar la_tortue » 21/03/2007, 14:08

Je n'y avais pas acces car la premiere ftentative je n'avais pas mis les droits :oops:

Maintenant c'est OK. Je suis meme en train d'installer les packets pour la carte graphique.

A+

Avatar de l’utilisateur
la_tortue
Newser
Newser
Messages : 1152
Enregistré le : 04/12/2006, 00:00
Localisation : fr

Messagepar la_tortue » 21/03/2007, 14:32

Salut
Donc après quelques tentatives infructueuses ça marche. Enfin un affichage fluide vous savez pas comment c'est bon!!!!

Bien donc pour en arriver la j'ai du installer les packets suivant :
- fglrx-control
- xorg-driver-fglrx
- xorg-driver-fglrx-dev
(pour les trouver faire une recherche sur fglrx dans synaptic)
une fois les packets mis il faut les installer et la c'est le lien de KZ2EDG qui ma dit comment faire. Dans un terminal (konsole pour ceux qui sont sous KDE) faire :
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

Et la c'est bon ça marche. Je n'est pas encore tout activé mais dieux que c'est bon d'avoir un defilement non saccadé!!!

Mainteant il me faut activer le direct rendering mais ça n'a pas l'air sorcié.


Par contre un truc que je ne comprend pas c'est pourquoi les piotes NVIDIA etaient installés eux :x

A+[/i]

Avatar de l’utilisateur
KZ2EDG
Modérateur
Modérateur
Messages : 330
Enregistré le : 21/12/2006, 00:00
Localisation : af

Messagepar KZ2EDG » 21/03/2007, 16:03

Content pour toi que ça fontionne. :cool:

je reviens au sujet de la présence des deux kernels au démarrage, chaque fois qu'il y à une mise à jour sur un kernel ou un nouveau kernel, celui-ci s'ajoute à la liste dans Grub. Dans mon cas je désinstalle le(s) kernel(s) en trop, mais il y a aussi la possibilité de modifier le fichier menu.lst relatif à Grub. Par contre le(s) kernel(s) seront toujours présents dans ce cas là. Certains sont adeptes de cette méthode au cas ou il y aurait un problème.(mais bon, au debut je me retrouvais avec 3 voire 4 kernels differents, j'ai choisi de faire le ménage)

Pour celà, il faut donc éditer (avec les droits) /boot/grub/menu.lst en ouvrant un terminal (Konsole sous KDE) et en mettant des # devant la ou les lignes que tu ne veux plus, sans oublier de faire la sauvegarde de menu.lst.

Au passage je signale que chaque version du kernel a 2 entrées :
- démarrage normal
- démarrage de mode dépannage (rescue)

Il faut donc commenter (avec des #) le couple de lignes relatif au kernel que l'on ne veut plus voir apparaitre. (et ne pas se tromper bien sûr)

@ciao! et bonne continuation.
:wink:
Ad augusta per angusta
Image

Avatar de l’utilisateur
la_tortue
Newser
Newser
Messages : 1152
Enregistré le : 04/12/2006, 00:00
Localisation : fr

Messagepar la_tortue » 21/03/2007, 16:17

Salut merci pour la solution alternative mais comme j'ai deja tout desinstaller (le chez risque de ne pas etre ccontent :???: ) Je l'ai juste mis dans le ficher log.

Maintenant je me prends le tete à installer apache,php,postgresql et phppgadmin.

J'ai vu que apache et php5 étaient deja present dans synaptic mais je ne vois pas trop comment faire. Si tu as une idée, je veux bien l'entendre.

A+

Avatar de l’utilisateur
KZ2EDG
Modérateur
Modérateur
Messages : 330
Enregistré le : 21/12/2006, 00:00
Localisation : af

Messagepar KZ2EDG » 21/03/2007, 16:36

Il te reste à installer postgresql et phppgadmin, pour celà tu fais une recherche dans synaptic et tu les trouveras rapidement. Il ne reste alors plus qu'à les installer (clic droit de la souris et selectionner pour installation).

Tu peux aussi réinstaller le kernel que tu as enlevé avant, si ça pose un problème.

:wink:
Ad augusta per angusta
Image

Avatar de l’utilisateur
la_tortue
Newser
Newser
Messages : 1152
Enregistré le : 04/12/2006, 00:00
Localisation : fr

Messagepar la_tortue » 22/03/2007, 15:39

Salut

Bon je donne un peu de mes nouvelles maintenant car les problemes que je rencontre sont minime (même si je met un temps monster pour les resoudre)

Donc :
- installation d'apache
- installation de postgresql
- installation de PHP
(tous ca en ligne de commande pas en utilisant synaptic ny les paquets - je suis un peu fier quand même)

- verif des configurations respectives :
- config apache/php OK
- config php/postgresql en cours


Maintenant je me demande s'il serait possible de passer en parametre aux commande 'su' et 'sudo' les mots de passe.
C'est pas top pour la securite mais comme je suis seul sur l'ordi et que c'est pour faire du developpement j'aimerais creer des alias pour lancer le serveur apache et postgresql avec une commande (une commande pour chaque logiciel) sans devoir m'inquieter de mon statut (root ou user) et sans avoir a retaper les mots de passe tout le temps.
Sinon est-il possible de configurer au moins apache pour qu'il demarre avec ubuntu? Normalement oui mais avec moi non (Chevalier Laspales)

A+

P.S.:Je commence à aimer Ubuntu :D

Avatar de l’utilisateur
KZ2EDG
Modérateur
Modérateur
Messages : 330
Enregistré le : 21/12/2006, 00:00
Localisation : af

Messagepar KZ2EDG » 22/03/2007, 22:16

Hello! :wink:

Apparemment ça se passe pas trop mal avec Ubuntu, en ce qui concerne l'activation du compte root, ça n'est pas conseillé, voici le lien de la doc Ubuntu y faisant référence: http://doc.ubuntu-fr.org/installation/compte_root

En ce qui concerne apache, peut être que ce lien (toujours la doc Ubuntu) te rendra service: http://doc.ubuntu-fr.org/serveur/lamp_bis

Pour terminer, quand tu dis avoir réalisé l'installation en ligne de commande, sans les paquets ni synaptic, tu as compilé avec les instructions configure,make, make install, non?

Bonne continuation, @ciao! :wink:
Ad augusta per angusta
Image

Avatar de l’utilisateur
la_tortue
Newser
Newser
Messages : 1152
Enregistré le : 04/12/2006, 00:00
Localisation : fr

Messagepar la_tortue » 23/03/2007, 09:25

C'est tout a fait exact j'ai compiler les sources (j'ai encore un peu de ma à comprendre toutes les configurations possible mais ça à l'air de marcher :cool: )

Pour le compte root j'avais bien compris qu'il ne fallais pas s'en servir mais utiliser la commande sudo. Je trouve ça meme tres agreable et pratique car je ne suis pas toujours en train d'appeler le chef pour les mots de passe.

Je pense que le tuto sur LAMP (moi c'est LAPP) va m'aider quelque peu, car j'ai un soucis bizare. Je m'explique, j'ai installer Postgresql et j'ai tenté une connextion à la base en tant qu'administrateur (compte postgres) -> ça fonctionne, joupi!!!!!
Fort de cette nouvelle exerience (j'ai enfin compiler mes premieres sources) je me lance dans l'install d'Apache et de PHP (dans cet ordre) dernieres versions.
Install d'Apache -> no souci, install de PHP -> no souci.
Je verifie donc que le module PHP pour Apache est bien la -> no souci.

WAHOU :content2: je suis le roi :roi: du petrole je vais enfin pouvoir coder :pc: et me regaler.

Je decide donc de remplir ma base Postgesql (en administrateur) et de creer un nouvel utilisateur (moi) avec des droits specifiques (creer une table, inserer des tuples et enfin faire des requetes). Mais la ça coince, je me peut plus me connecter à la base ARG :twisted: (remise en question d'une journée qui avais l'air superbe)
Erreur du type connexion impossible pas de fichier ou repertoire...

Bon, ouf, il est plus de 17H il me faut partir (je suis en plein demenagement).

Me voici aujourd'hui plein d'entrain, ça va marcher bordel!!!!!!!!!!!!!!, il me faut travailler un peu (assez pour justifier 600€ / mois sachant que je suis en stage)

Voila ou Jean suis (dit donc de bon matin ça attaque fort)

A+


Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité